Intermittent website failures
Incident Report for Bounce Boss
Resolved
This incident has been resolved.
Posted May 22, 2020 - 15:43 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 22, 2020 - 12:11 UTC
Investigating
We are currently investigating this issue.
Posted May 22, 2020 - 11:53 UTC
This incident affected: Website.